Get in touch
Back
Resolved

Hosting provider outage

Started 28 Apr at 11:12pm CEST.

Website Web Server
Created

Our hosting provider experienced an issue that caused intermittent server unavailability for approximately 2 hours. The problem has been resolved and services have been fully restored.

Posted 28 Apr at 11:12pm CEST.